Zum Zubehör Shop      Avatar ändern
 
Antwort schreiben 
[erledigt] XBian und DLINK DWL-G122 Wlan Adapter Problem
15.07.2013, 16:20
Beitrag #1
XBian und DLINK DWL-G122 Wlan Adapter Problem
Hi,

hab den Wlan Adapter DWL-G122 in das Raspebrry eingesteckt und dabei Startet das System ein Xbian ohne USB Unterstützt oder /und bei einstecken im laufenden betrieb startet es einfach komplett neu.

Ich komme nicht einmal mehr dazu mir de dmesg Ausgabe anzeigen zu lassen um irgendwelche fehler zu finden.

Ich kann nur dazu sagen: Treiber konflikt und die USB Tastatur geht dann auch nicht mehr.

weiss jemand rat hier?

Hatte das problem bei nem normalen Raspbian beispielsweise nicht.
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
15.07.2013, 16:43
Beitrag #2
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
Irgendwie ist dein Post verwirrend geschrieben Icon_wink.

also wenn du im laufenden Betrieb dein WLAN Stick anschliesst, startet dein Pi neu? Wenn er dann neu gestartet ist, hast du keinen USB Support mehr?
Du könntest dich per Kabel und ssh auf den Pi connecten um eine weitere Fehlersuche zu betreiben.

Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
15.07.2013, 17:20
Beitrag #3
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
(15.07.2013 16:43)dbv schrieb:  Irgendwie ist dein Post verwirrend geschrieben Icon_wink.

also wenn du im laufenden Betrieb dein WLAN Stick anschliesst, startet dein Pi neu? Wenn er dann neu gestartet ist, hast du keinen USB Support mehr?
Du könntest dich per Kabel und ssh auf den Pi connecten um eine weitere Fehlersuche zu betreiben.

Naja dbv, passt doch ...
WLAN rein -> spannung bricht ein -> reboot -> zu wenig Saft = kein Netz, kein USB ... nix Icon_wink

Guter Entschluss, einen Adminposten zu übernehmen Icon_smile ...

cu,
-ds-

Kreative Pause ... Icon_sleep ... mir fällt im Moment nix mehr ein.
Vielleicht werdet ihr ja im Archiv fündig.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
15.07.2013, 17:25
Beitrag #4
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
Das er gar nicht mehr angeht konnte ich aus seinem Post nicht entnehmen. Wenn dem so ist, überlasse ich ihn deinen fähigen Händen...ich halte mich aus allem raus was mit Strom zu tun hat Icon_smile

Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
15.07.2013, 17:31
Beitrag #5
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
(15.07.2013 17:25)dbv schrieb:  Das er gar nicht mehr angeht konnte ich aus seinem Post nicht entnehmen. Wenn dem so ist, überlasse ich ihn deinen fähigen Händen...ich halte mich aus allem raus was mit Strom zu tun hat Icon_smile

Das ist ja das gemeine daran ... er geht ja wieder an. Aber eben nur der Professor Icon_smile ... alles andere tut nicht.

Ok, dann lieber Eröffner dieses Threads, erzähl uns mal, wie Du deinen RPi angeschlossen hast, was Du für ein Netzteil verwendest und was Du sonst noch so in die Gehäuseöffnungen Deines Pi gesteckt hast Icon_wink ...

cu,
-ds-

Kreative Pause ... Icon_sleep ... mir fällt im Moment nix mehr ein.
Vielleicht werdet ihr ja im Archiv fündig.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
15.07.2013, 17:52 (Dieser Beitrag wurde zuletzt bearbeitet: 15.07.2013 18:30 von boandlkramer. )
Beitrag #6
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
Ja genau wie du es beschrieben hast ist der Sachverghalt, sry für die Unverständliche schriebweise ^^

Ich kann übrigends nur per ssh zugreifen wenn ich xbmc ausschalte als dienst.. hmms cheint wohl daran dann zu liegen? :\

hier mal ein auszug aus der dmesg ohne xbmc:

[    2.588327] smsc95xx 1-1.1:1.0: eth0: register 'smsc95xx' at usb-bcm2708_usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:f2:d5:4e
[    2.684012] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[    2.957837] usb 1-1.2: New USB device found, idVendor=2001, idProduct=3c00
[    2.957864] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    2.957879] usb 1-1.2: Product: 802.11g WLAN Adapter
[    2.957890] usb 1-1.2: Manufacturer: ANI
[   10.511057] EXT4-fs (mmcblk0p2): recovery complete
[   10.620074] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
[   14.072252] cfg80211: Calling CRDA to update world regulatory domain
[   14.434148] usb 1-1.2: reset high-speed USB device number 4 using dwc_otg
[   14.766333] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   14.767225] Registered led device: rt2500usb-phy0::radio
[   14.767335] Registered led device: rt2500usb-phy0::quality
[   14.768871] usbcore: registered new interface driver rt2500usb
[   14.922086] cfg80211: World regulatory domain updated:
[   14.922115] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   14.922131] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   14.922143] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   14.922155] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   14.922166] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   14.922177] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   17.403886] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[   17.863558] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[   18.452729] bcm2835 ALSA card created!
[   18.452955] bcm2835 ALSA chip created!
[   18.453115] bcm2835 ALSA chip created!
[   18.453258] bcm2835 ALSA chip created!
[   18.453395] bcm2835 ALSA chip created!
[   18.453530] bcm2835 ALSA chip created!
[   18.457304] bcm2835 ALSA chip created!
[   18.457478] bcm2835 ALSA chip created!
[   18.564760] bcm2708 watchdog, heartbeat=10 sec (nowayout=0)
[   21.856155] Adding 127996k swap on /var/swapfile.  Priority:-1 extents:2 across:152572k SS
[   26.030472] Installing knfsd (copyright (C) 1996 [email protected]).
[   26.383161] smsc95xx 1-1.1:1.0: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   28.446400] wlan0: authenticate with
[   28.478301] wlan0: send auth to 74:31:90:90:48:6e (try 1/3)
[   28.480529] wlan0: authenticated
[   28.481232] rt2500usb 1-1.2:1.0: wlan0: disabling HT as WMM/QoS is not supported
[   28.503920] wlan0: associate with 74:31:90:90:48:6e (try 1/3)
[   28.506882] wlan0: RX AssocResp from 74:91:90:55:98:6e (capab=0x411 status=0 aid=2)
[   28.508701] wlan0: associated
[   28.509003] cfg80211: Calling CRDA for country: DE
[   28.633365] cfg80211: Regulatory domain changed to country: DE
[   28.633393] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   28.633406] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   28.633417] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   28.633428] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   28.633439] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
15.07.2013, 18:36
Beitrag #7
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
Hallo trashtalk,

wie hier schon von dreamshader gepostet solltest du mal deine Beschaltung beschreiben. Ich gehe mal davon aus, dass du Tastatur und WLAN-Adapter direkt am Raspberry Pi angeschlossen hast. Wenn dem so ist, dann solltest du mal einen aktiven USB-Hub zwischen Raspberry Pi und deinen USB-Geräten hängen.
Das Problem ist, dass der Raspberry Pi nicht genügend Strom an den USB-Ports zur Verfügung stellen kann. Wie in deinem Fall kommt es dann zu Systemsbstürzen und Problemen mit den USB-Geräten und dem ganzen System. Daher sollte man einen aktiven USB-Hub verwenden um solche Probleme zu vermeiden.

Gruß Georg
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
16.07.2013, 00:44
Beitrag #8
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
es steckt ein normales nt 9v dran ein netzwerkkabel und der wlan adapter. trotzdem stürzt es ab. auch mit aktiven hub. sobald ich xbmc beende brichtnichts mehr zusammen.
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
16.07.2013, 15:54
Beitrag #9
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
kleiner nachtrag: es könnte vllt auch an xbmc liegen das dieser dienst zu viel strom zieht, wobei diese vermutung wohl kompletter humbug ist den ich mal Icon_biggrin2

es ist wie gesagt ohne xbmc ohne probleme möglich den wlan stick einzustecken, dieser wird vom treiber normal initialisiert und erkannt.

probleme gibt es aber nun auch wenn ich zB lxde als x11 starte.
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
16.07.2013, 16:38 (Dieser Beitrag wurde zuletzt bearbeitet: 16.07.2013 16:46 von dreamshader. )
Beitrag #10
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
(16.07.2013 00:44)trashtalk schrieb:  es steckt ein normales nt 9v dran ein netzwerkkabel und der wlan adapter. trotzdem stürzt es ab. auch mit aktiven hub. sobald ich xbmc beende brichtnichts mehr zusammen.

Hi, Du meinst ein 5V Netzteil Icon_wink ...

Aber definiere mal "normal" ...
Ein bisschen mehr Info über die Verkabelung wäre auch nicht schlecht.

cu,
-ds-

(16.07.2013 15:54)trashtalk schrieb:  kleiner nachtrag: es könnte vllt auch an xbmc liegen das dieser dienst zu viel strom zieht, wobei diese vermutung wohl kompletter humbug ist den ich mal Icon_biggrin2

es ist wie gesagt ohne xbmc ohne probleme möglich den wlan stick einzustecken, dieser wird vom treiber normal initialisiert und erkannt.

probleme gibt es aber nun auch wenn ich zB lxde als x11 starte.

So abwegig ist das m.E. gar nicht ...

Der Prozessor regelt seine Leistung nach Anforderung ...
Wenn jetzt eben mehr Leistung gefragt ist, taktet er hoch bis zum eingestellten Limit.
Dadurch zieht er vermutlich auch mehr Strom ... und kommt damit evtl. über die Grenze der Spannungsversorgung ...

Also aus meiner Sicht durchaus möglich,
-ds-

Kreative Pause ... Icon_sleep ... mir fällt im Moment nix mehr ein.
Vielleicht werdet ihr ja im Archiv fündig.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
16.07.2013, 17:36
Beitrag #11
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
okay kleines update:

aktiven HUB genommen, und tatsächlich kein Absturz. (inkl. tastatur und xbmc dienst am laufen)

und rasperry auch anpingbar. nur möchte ich das mit dem aktiven hib nicht als Lösung akzeptieren, weil dann die Verkabelung doch wieder immens ist :\

NUnja:

Also ich nutze wie gesagt den DLink stick, der wohl auch nicht so das gelbe vom ei ist, würde auch gerne auf alternativen umsteigen.

Als Tastatur nutze ich eine Apple Tastatur weil ich a.t.m. leider keine andere USB tastatur besitze.

Und ja es ist natürlich ein 5V NT sry^^
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
16.07.2013, 17:45
Beitrag #12
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
Naja ... dann ist dieses Problem zumindest mal gelöst (als erledigt markieren bitte nicht vergessen)

Ansonsten ist es etwas schwierig, denn ich fürchte, dass Du da nur wenig Spielraum hast.
Vllt. wäre ja eine Fernbedienung statt Tastatus/Maus sinnvoll ... aber wirklich Strom sparen wirst Du dadurch vermutlich auch nicht.
Und ein anderer WLAN-Adapter wird in dieser Richtung auch nicht wirklich viel bringen ...

Also dann, trotzdem noch viel Spass mit dem Krümel,
-ds-

Kreative Pause ... Icon_sleep ... mir fällt im Moment nix mehr ein.
Vielleicht werdet ihr ja im Archiv fündig.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
16.07.2013, 18:29
Beitrag #13
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
aber die frage bleibt noch warum es bei macnhen anderen klappt mit wlan adapter un tastatur, gibt es da unterschiede, und wie ereknne ich wieviel jeweils ein adapter un wieviel eine tatsur an mA schluckt?
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
16.07.2013, 18:55
Beitrag #14
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
(16.07.2013 18:29)trashtalk schrieb:  aber die frage bleibt noch warum es bei macnhen anderen klappt mit wlan adapter un tastatur, gibt es da unterschiede, und wie ereknne ich wieviel jeweils ein adapter un wieviel eine tatsur an mA schluckt?

Schwierige Frage ...
sicher wirds da Unterschiede geben. was die einzelnen Komponenten brauchen, sollte auf den Geräten bzw. der Anleitung angegeben sein.
Das einzige, was mir jetzt ad hoc einfällt ist jemanden, bei dem es funktioniert, zu fragen was er verwendet.

cu,
-ds-

Kreative Pause ... Icon_sleep ... mir fällt im Moment nix mehr ein.
Vielleicht werdet ihr ja im Archiv fündig.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
17.07.2013, 15:42
Beitrag #15
RE: XBian und DLINK DWL-G122 Wlan Adapter Problem
(16.07.2013 18:55)dreamshader schrieb:  
(16.07.2013 18:29)trashtalk schrieb:  aber die frage bleibt noch warum es bei macnhen anderen klappt mit wlan adapter un tastatur, gibt es da unterschiede, und wie ereknne ich wieviel jeweils ein adapter un wieviel eine tatsur an mA schluckt?

Schwierige Frage ...
sicher wirds da Unterschiede geben. was die einzelnen Komponenten brauchen, sollte auf den Geräten bzw. der Anleitung angegeben sein.
Das einzige, was mir jetzt ad hoc einfällt ist jemanden, bei dem es funktioniert, zu fragen was er verwendet.

cu,
-ds-

ja das würd emich auch mal interessieren, welche wlan adapter die anderen user so nutzen? gibt es da einen den amn ganz besonders für das raspi empfehlen könnte?
Alle Beiträge dieses Benutzers finden
Like Post Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Wenn dein Problem oder deine Frage geklärt worden ist markiere bitte dein Thema als "erledigt" indem du auf den "Erledigt-Button" klickst.

Vielen Dank!


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  [Raspbian] RPI Cam Control Problem masterpoly 0 64 14.08.2014 21:12
Letzter Beitrag: masterpoly
  [Raspbian] Problem XRDP Raspian JulianS. 19 543 07.08.2014 19:33
Letzter Beitrag: wusa
  [Raspbian] Wlan bridge aufbauen Raspberryverrückter 5 247 01.08.2014 23:08
Letzter Beitrag: Raspberryverrückter
  [Raspbian] Problem mit Webserver bootsmann 1 150 25.07.2014 10:40
Letzter Beitrag: bootsmann
  [Raspbian] Problem beim Mounten von Audio CD´s Kartonage 1 109 13.07.2014 16:54
Letzter Beitrag: Kartonage
  [Raspbian] Edimax EW-7811UN als Access Point Problem Hobirath 9 474 13.07.2014 09:11
Letzter Beitrag: gf31011601
  [Raspbian] Raspbian 2014 Static IP Problem Racer5495 5 226 10.06.2014 12:54
Letzter Beitrag: Racer5495
  [Raspbian] HDMI-VGA Adapter --> Kein Bild bei Raspbian! RaspiMaster 2 462 19.05.2014 14:26
Letzter Beitrag: RaspiMaster
  [Raspbian (NOOBS)] Problem mit XBMC auf Raspbian Gabriel 1 331 17.05.2014 11:45
Letzter Beitrag: pfarrerbraun
  [Raspbian] WLAN-Verbindung bricht ab? rodial 3 573 25.04.2014 10:57
Letzter Beitrag: Andreas



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
IRC ChatZum Chatroom